Adds basic build setup.

pull/1/head
Abhinav Sarkar 7 years ago
parent 7f5dab0b21
commit 7db306602f
  1. 1
      .gitignore
  2. 2
      Setup.hs
  3. 6
      app/Main.hs
  4. 39
      ringo.cabal
  5. 2
      src/Ringo.hs
  6. 29
      stack.yaml
  7. 2
      test/Spec.hs

1
.gitignore vendored

@ -11,6 +11,7 @@ cabal-dev
.hsenv
.cabal-sandbox/
cabal.sandbox.config
.stack-work/
*.prof
*.aux
*.hp

@ -0,0 +1,2 @@
import Distribution.Simple
main = defaultMain

@ -0,0 +1,6 @@
module Main where
import Ringo
main :: IO ()
main = undefined

@ -0,0 +1,39 @@
name: ringo
version: 0.1.0.0
synopsis: Tool to transform OLTP database schemas to OLAP database schemas automatically
description: Please see README.md
homepage: http://github.com/quintype/ringo#readme
license: MIT
license-file: LICENSE
author: Abhinav Sarkar
maintainer: abhinav@abhinavsarkar.net
copyright: 2015 Quintype Inc, Nilenso Software LLP
category: SQL
build-type: Simple
-- extra-source-files:
cabal-version: >=1.20
library
hs-source-dirs: src
exposed-modules: Ringo
build-depends: base >= 4.7 && < 5
default-language: Haskell2010
executable ringo
hs-source-dirs: app
main-is: Main.hs
build-depends: base
, ringo
default-language: Haskell2010
test-suite ringo-test
type: exitcode-stdio-1.0
hs-source-dirs: test
main-is: Spec.hs
build-depends: base
, ringo
default-language: Haskell2010
source-repository head
type: git
location: https://github.com/quintype/ringo

@ -0,0 +1,2 @@
module Ringo
() where

@ -0,0 +1,29 @@
# For more information, see: https://github.com/commercialhaskell/stack/blob/master/doc/yaml_configuration.md
# Specifies the GHC version and set of packages available (e.g., lts-3.5, nightly-2015-09-21, ghc-7.10.2)
resolver: lts-3.6
# Local packages, usually specified by relative directory name
packages:
- '.'
# Packages to be pulled from upstream that are not in the resolver (e.g., acme-missiles-0.3)
extra-deps: []
# Override default flag values for local packages and extra-deps
flags: {}
# Control whether we use the GHC we find on the path
# system-ghc: true
# Require a specific version of stack, using version ranges
# require-stack-version: -any # Default
# require-stack-version: >= 0.1.4.0
# Override the architecture used by stack, especially useful on Windows
# arch: i386
# arch: x86_64
# Extra directories used by stack for building
# extra-include-dirs: [/path/to/dir]
# extra-lib-dirs: [/path/to/dir]

@ -0,0 +1,2 @@
main :: IO ()
main = putStrLn "Test suite not yet implemented"
Loading…
Cancel
Save