Browse Source

Changes base and integer-gmp versions to fix multi ghc build.

Abhinav Sarkar 5 years ago
parent
commit
fd3932daad

+ 0
- 1
hask-irc-core/cabal.config View File

@@ -31,7 +31,6 @@ constraints: ReadArgs ==1.2.2,
31 31
              hask-irc-core ==0.1.0,
32 32
              hslogger ==1.2.9,
33 33
              hslogger-template ==2.0.3,
34
-             integer-gmp ==0.5.1.0,
35 34
              kan-extensions ==4.2.2,
36 35
              keys ==3.10.2,
37 36
              lifted-base ==0.2.3.6,

+ 1
- 1
hask-irc-core/hask-irc-core.cabal View File

@@ -53,7 +53,7 @@ library
53 53
                        BangPatterns, TupleSections, NamedFieldPuns, GeneralizedNewtypeDeriving,
54 54
                        DeriveDataTypeable, Trustworthy
55 55
 
56
-  build-depends:       base                 >=4.5     && <4.8,
56
+  build-depends:       base                 >=4.5     && <4.9,
57 57
                        classy-prelude       >=0.10    && <1.0,
58 58
                        convertible          >=1.1     && <1.2,
59 59
                        hslogger             >=1.2     && <1.3,

+ 0
- 1
hask-irc-handlers/cabal.config View File

@@ -42,7 +42,6 @@ constraints: HTTP ==4000.2.20,
42 42
              hask-irc-handlers ==0.1.0,
43 43
              hslogger ==1.2.9,
44 44
              hslogger-template ==2.0.3,
45
-             integer-gmp ==0.5.1.0,
46 45
              ixset ==1.0.6,
47 46
              kan-extensions ==4.2.2,
48 47
              keys ==3.10.2,

+ 1
- 1
hask-irc-handlers/hask-irc-handlers.cabal View File

@@ -53,7 +53,7 @@ library
53 53
                        BangPatterns, TupleSections, NamedFieldPuns, GeneralizedNewtypeDeriving,
54 54
                        DeriveDataTypeable
55 55
 
56
-  build-depends:       base                 >=4.5     && <4.8,
56
+  build-depends:       base                 >=4.5     && <4.9,
57 57
                        hask-irc-core        ==0.1.0,
58 58
                        acid-state           >=0.12    && <0.13,
59 59
                        aeson                >=0.7     && <0.8,

+ 0
- 1
hask-irc-runner/cabal.config View File

@@ -44,7 +44,6 @@ constraints: HTTP ==4000.2.20,
44 44
              hask-irc-runner ==0.1.0,
45 45
              hslogger ==1.2.9,
46 46
              hslogger-template ==2.0.3,
47
-             integer-gmp ==0.5.1.0,
48 47
              ixset ==1.0.6,
49 48
              kan-extensions ==4.2.2,
50 49
              keys ==3.10.2,

+ 1
- 1
hask-irc-runner/hask-irc-runner.cabal View File

@@ -60,7 +60,7 @@ executable hask-irc
60 60
                        DeriveDataTypeable
61 61
 
62 62
   -- Other library packages from which modules are imported.
63
-  build-depends:       base                 >=4.5     && <4.8,
63
+  build-depends:       base                 >=4.5     && <4.9,
64 64
                        hask-irc-core        ==0.1.0,
65 65
                        hask-irc-handlers    ==0.1.0,
66 66
                        classy-prelude       >=0.10    && <1.0,

Loading…
Cancel
Save